Управление сетями с помощью VLAN на примере Cisco ISR 886 и коммутаторов TP-Link, HP

 Примерная схема сети:

 Задача: реализовать корпоративный и гостевой WiFi доступ с помощью VLAN.

 Первым делом необходимо создать VLAN на Cisco. Для Cisco C886VA:

conf t
(config)#interface Vlan1
(config-if)#description System VLAN #Это управляющий VLAN, к которому будет подключаться всё оборудование
(config-if)#ip address 10.254.1.1 255.255.255.0
(config-if)#ip mtu 1492
(config-if)#ip nbar protocol-discovery ipv4
(config-if)#ip flow ingress
(config-if)#ip nat inside
(config-if)#ip virtual-reassembly in max-reassemblies 64

(config-if)#exit
(config)#interface Vlan401
(config-if)#description LAN
(config-if)#ip address 192.168.1.1 255.255.255.0
(config-if)#ip mtu 1492
(config-if)#ip nbar protocol-discovery ipv4
(config-if)#ip flow ingress
(config-if)#ip nat inside
(config-if)#ip virtual-reassembly in max-reassemblies 64
(config-if)#exit

(config)#interface Vlan402
(config-if)#description Guest WiFi
(config-if)#ip address 192.168.2.1 255.255.255.0
(config-if)#ip helper-address 192.168.1.10
(config-if)#ip mtu 1492
(config-if)#ip nbar protocol-discovery ipv4
(config-if)#ip flow ingress
(config-if)#ip nat inside
(config-if)#ip virtual-reassembly in max-reassemblies 64
(config-if)#exit

(config)#vlan 1
(config-vlan)#exit

(config)#vlan 401
(config-vlan)#exit

(config)#vlan 402
(config-vlan)#exit

(config)#interface FastEthernet0
(config-if)#description Trunk
(config-if)#switchport mode trunk
(config-if)#no ip address
(config-if)end
#wr

 Проверяем наличие VLAN в транке:

#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Fa0 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa0 1-4094

Port Vlans allowed and active in management domain
Fa0 1,401-402

Port Vlans in spanning tree forwarding state and not pruned
Fa0 1,401-402
 
 А теперь начинается самое интересное - настройка коммутаторов и точки доступа. Для начала создадим VLAN на коммутаторах:
 
 
 Назначим транковые порты (тегированные): 1 - входящий от Cisco, 4 - исходящий в HPE Switch:
 
 В итоге будет такая картина на TP-Link:
 
 
 Теперь "примем" VLAN на коммутаторе HPE. Начнём как всегда с создания (почему-то в Chrome невозможно работать в панели упраления HPE, я использовал FireFox). Настройка отличается от коммутаторов HPE:
 
 В HPE Транки настриваются по-другому. Первый порт становится членом Транка №1:
 
 Финальная картина выглядит так. К 6-му порту будет подключена точка доступа.
 
 Теперь правильно настроим VLAN на портах HPE. Для этого нужно зайти в VLAN - Port Membership, выбрать нужный VLAN и назначить на портах. Untagget порт это тоже самое, что у Cisco - switch port access vlan 402. Другими словами (непрофессиональными), порт принадлежит данному VLAN, и устройство подключенное к этому порту, колучит IP адрес из этого VLAN. 1 и 6 порты настроить нельзя, так как они являются членами Транков. Это означает (снова непрофессиональное определение), что устройство подключённое к этому порту так же должно быть настроено на транк! Исключение составляет системный\управляющий VLAN, по которому обычно и подключают точки доступа. В моём случае VLAN 1 в сети 10.254.1.0.24.
 
 Теперь настроим точку доступа. Создадим WiFi с соответствующими VLAN. В качестве WiFi мы используем решение от UniFi:
 
 
 Точка доступа подключается к 6-му порту HPE. Напомню, что тот порт является транковым и прописан в настройках VLAN 401\402 на HPE.