Рабочая конфигурация для Cisco ISR C886VA для VDSL (Deutsche Telekom)

 В первую очередь необходимо обновить прошивку как минимум до 2018 года потому, что только новые прошивки поддерживают Vectoring. Без Vectoring максимальная возможная скорость VDSL - 50/10. С Vectoring 100/40 (может больше).

sh ver

Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.4(3)M10, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Wed 08-Aug-18 06:30 by prod_rel_team
 Полный рабочий конфиг с комментариями:
sh run

Building configuration...

Current configuration : 8019 bytes
!
! Last configuration change at 14:27:25 UTC Fri Jan 25 2019 by admin
! NVRAM config last updated at 14:27:34 UTC Fri Jan 25 2019 by admin
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname somename.dyndns.org
!
boot-start-marker
boot system flash:c800-universalk9-mz.SPA.154-3.M10.bin
boot-end-marker
!
aqm-register-fnf
!
enable secret 5 ---------------------------
!
aaa new-model
!
aaa session-id common
clock timezone UTC 2 0
!
ip flow-cache timeout active 1
ip domain name domain.com
ip ddns update method dyndns
remark мы используем DYNDNS для динамического S2S VPN, необязательная настройка
HTTP
add http://user:[email protected]/nic/update?system=dyndns&hostname=<h>&myip=<a>
interval maximum 1 0 0 0
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C886VA-K9 sn FCZ2044B08C
!
username admin privilege 15 secret 5 -----------------------
!
controller VDSL 0
firmware filename flash:VA_B_38V_d24m.bin
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
remark это покажется странным, но у нас подключение VDSL по порту Ethernet
!
interface ATM0.1 point-to-point
pvc 1/32
pppoe-client dial-pool-number 1
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface Ethernet0
description WAN
no ip address
ip nbar protocol-discovery ipv4
service-policy input Hosts
!
interface Ethernet0.7
remark Deutsche Telekom использует 7 VLAN, у других провайдеров может отличаться
description VDSL VLAN 7 tagged
encapsulation dot1Q 7
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0
remark внутренний порт, к которому подключается коммутатор
description Trunk
switchport mode trunk
no ip address
!
interface FastEthernet1
no ip address
shutdown
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface Vlan1
remark внутренняя сеть
description LAN
ip address 192.168.1.1 255.255.255.0
ip mtu 1492
ip nbar protocol-discovery ipv4
ip flow ingress
ip nat inside
ip virtual-reassembly in max-reassemblies 64
!
interface Dialer0
remark внешний виртуальный интерфейс
description VDSL TELEKOM
ip ddns update hostname somename.dyndns.org
ip ddns update dyndns
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nbar protocol-discovery ipv4
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
load-interval 30
dialer pool 1
dialer-group 1
no keepalive
ppp authentication pap callin
remark учётные данные должны быть прописаны в контракте
ppp pap sent-username [email protected] password 7 ------------------------
ppp ipcp dns request
ppp ipcp mask request
ppp ipcp route default
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat translation tcp-timeout 14400
remark правило, включающее натирование на интерфейсе Dialer0
ip nat inside source list 101 interface Dialer0 overload
!
remark правило Firewall, разрешающее подключение к Cisco по SSH с внутренней сети
access-list 22 permit 192.168.1.0 0.0.0.255
remark правило Firewall, разрешающее трафик из внутренней сети в интернет (всё остальное по умолчанию запрещено)
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
vstack
!
line con 0
password 7 -------------------------------
no modem enable
line aux 0
line vty 0 4
access-class 22 in
exec-timeout 30 0
password 7 -------------------------------
logging synchronous
transport input ssh
line vty 5 189
exec-timeout 30 0
password 7 -------------------------------
logging synchronous
transport input ssh
!
scheduler allocate 20000 1000
ntp server 192.168.1.9
!
end

 

Рабочая конфигурация для Cisco ISR 2851 для Ethernet

sh ver

Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(25a), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 22-May-09 22:00 by prod_rel_team

 Полный рабочий конфиг с комментариями:

sh run

Building configuration...

Current configuration : 8824 bytes
!
! Last configuration change at 11:08:55 CET Thu Jan 24 2019 by admin
! NVRAM config last updated at 11:09:00 CET Thu Jan 24 2019 by admin
!
version 12.4
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname router.domain.com
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.124-25a.bin
boot-end-marker
!
logging buffered 1024000 warnings
logging console warnings
logging monitor informational
enable secret 5 ------------------------
!
no aaa new-model
clock timezone CET 1
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00
!
ip cef
no ip dhcp use vrf connected
!
ip domain name domain.com
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
voice-card 0
no dspfarm
!
!
username root privilege 15 secret 5 ---------------------------
archive
log config
hidekeys
!
ip ssh version 2
!
interface GigabitEthernet0/0
description WAN to ISP
remark назначаем внешний статический IP на гигабитный интерфейс
ip address XXX.XXX.XXX.XXX 255.255.255.0
ip nat outside
ip virtual-reassembly
load-interval 30
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.301
remark создаём VLAN для рабочих станций
description Workstations VLAN
encapsulation dot1Q 301
ip address 10.253.1.1 255.255.255.0
remark указываем DHCP сервер, ответственный за сеть

ip helper-address 10.253.2.12
ip nat inside
ip virtual-reassembly
!
interface GigabitEthernet0/1.302
remark создаём VLAN для серверов
description Servers VLAN
encapsulation dot1Q 302
ip address 10.253.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
remark задаём шлюз по умолчанию
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX 250 name DEFAULT
!
no ip http server
no ip http secure-server
remark включаем натирование для сетей из списка LAN4NAT на внешнем интерфейсе
ip nat inside source list LAN4NAT interface GigabitEthernet0/0 overload
!
remark разрешаем трафик между локальными сетями и Интернетом
ip access-list extended LAN4NAT
permit ip 10.253.1.0 0.0.0.255 any
permit ip 10.253.2.0 0.0.0.255 any
!
remark задаём сеть, с которой могут подлкючаться админы по SSH
ip access-list extended ADMIN_ACCESS
permit ip 10.253.2.0 0.0.0.255 any
!
control-plane
!
line con 0
exec-timeout 30 0
logging synchronous
line aux 0
exec-timeout 30 0
logging synchronous
line vty 0 4
access-class ADMIN_ACCESS in
exec-timeout 15 0
login local
transport input ssh
line vty 5 1180
access-class ADMIN_ACCESS in
exec-timeout 15 0
login local
transport input ssh
!
scheduler allocate 20000 1000
remark настройка синхронизации времени
ntp clock-period 17180341
ntp source GigabitEthernet0/1.301
ntp master 4
ntp update-calendar
ntp server XXX.XXX.XXX.XXX
ntp server YYY.YYY.YYY.YYY
!
end

26.01.2019